Supervisor管理器

如果宝塔版本是低于 7.9 可以选用supervisor 管理器,宝塔7.9及以上版本此工具可能出BUG,请选择 堡塔应用管理器跳过本页,看堡塔应用管理器

Supervisor 管理器堡塔应用管理器 二选一使用

步骤总结:

一、切换PHP命令行版本和站点一致。
二、在Supervisor管理器里添加守护进程。

步骤详解:

1.修改命令行 php 版本

2.选中使用的 php 版本(这里以 php7.3为例)

3.打开软件商店找到 Supervisor管理器

4.点开添加守护进程

5.填写名称(自定义填写) , 启动用户www。然后点击选择运行目录

注意:名称只能为英文名称

6.选择程序目录,这里以/www/wwwroot/ 为例。(如果您的系统在数据盘挂在,则选择数据盘)

7.勾选程序目录文件夹,然后点击选择

8.填写启动命令: php think swoole

9.点击确定添加进程守护,然后点击[启动]


注:
1、如遇到添加完成后,守护进程里空白无内容,请更新宝塔面板及软件版本。
2、如遇到添加完成后,守护进程启动失败,请检查php命令行版本或者检查下禁用函数是否删除了proc_open
服务器配置完毕,下一步,程序一键安装
**3、看下守护进程日志,或者在命令行模式运行php think swoole;查看错误信息

信息如下:乱码输出


请手动复制help/swoole_loader/对应php版本解密扩展文件(放在php扩展目录),然后重启php

如下错误:


请检查命令行版本php -v,命令行版本要和站点版本一致

如下错误


说明你的加密文件是7.3版本;解密扩展是7.4版本
可以复制对应help/7.4下文件替换

如下则表示:启动成功,可以关闭命令行窗口,在守护进程中添加启动

服务器配置完毕,下一步,程序一键安装