关于composer更新的问题

从Prov2.2版本之后composer安装的扩展基本要求php版本要在7.4之上包括7.4

为了用户安装可以选择多个php版本,无奈之下改了vendor兼容了7.1-7.4版本,但是我们强烈建议您使用php7.4版本。

如果开发者想更新composer一定要切换到php7.4版本进行安装扩展;

问题1:composer update 更新后队列无法执行,各种报错

可能原因: 可能原因是自动升级了think-queue;可能原因是升级了各种扩展导致不兼容或者类文件丢失等等。问题很多;
处理方法:不要盲目使用composer update,如果需要更新某个扩展请使用:

问题2:多个php版本开发中应该选择哪个版本?

答: 果断选择PHP7.4,可能会在之后版本逐渐淘汰7.4之下的版本;也是为了更好的性能;

问题3: composer怎么安装指定版本扩展?

答: composer require 扩展名:~5.0

问题4: composer require 某个扩展后无法启动项目,vendor/services.php 文件内为空,怎么办?

答: 使用:composer dump-autoload 执行后再看下此文件是否为空